`
473687880
  • 浏览: 484822 次
文章分类
社区版块
存档分类
最新评论

The Settlers of Catan UVA539

阅读更多



The Settlers of Catan

WithinSettlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness.

You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules:


When the game ends, the player who built the longest road gains two extra victory points.


The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately).


Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though.


Example: The following network contains a road of length 12.

o        o -- o        o
 \      /      \      /
  o -- o        o -- o
 /      \      /      \
o        o -- o        o -- o
               \      /
                o -- o

Input

The input file will contain one or more test cases.

The first line of each test case contains two integers: the number of nodesn($2 \le n \le 25$) and the number of edgesm($1 \le m \le 25$). The nextmlines describe themedges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 ton-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected.

Input will be terminated by two values of 0 fornandm.

Output

For each test case, print the length of the longest road on a single line.

Sample Input

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output

2
12



Miguel A. Revilla
1999-01-11


求图中的一条最长路径,又是回溯。
#include<iostream>
#include<cstring>

using namespace std;

int grid[30][30],vis[30][30];
int len,maxlen,n;

void dfs(int posx,int posy)
{
    len++;
    int i,j,k;
    for(i=0;i<n;i++)
    {
        if(grid[posy][i]==1&&vis[posy][i]==0&&i!=posx)
        {
            vis[posy][i]=1;
            vis[i][posy]=1;
            dfs(posy,i);
            len--;
            vis[posy][i]=0;
            vis[i][posy]=0;
        }
    }
    if(len>maxlen) maxlen=len;
}

int main()
{
    int m;
    while(cin>>n>>m&&(n!=0||m!=0))
    {
        memset(grid,0,sizeof(grid));
        memset(vis,0,sizeof(vis));
        int i,j;
        for(i=0;i<m;i++)
        {
            int x,y;
            cin>>x>>y;
            grid[x][y]=grid[y][x]=1;
        }
        maxlen=0;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(grid[i][j]&&vis[i][j]==0)
                {
                    memset(vis,0,sizeof(vis));
                    len=0;
                    vis[i][j]=1;
                    vis[j][i]=1;
                    dfs(i,j);
                }
            }
        }
        cout<<maxlen<<endl;
    }
    return 0;
}



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics