`
473687880
  • 浏览: 485475 次
文章分类
社区版块
存档分类
最新评论

Bicoloring UVA 10004

 
阅读更多



Bicoloring

In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region.

Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:

  • no node will have an edge to itself.
  • the graph is nondirected. That is, if a nodeais said to be connected to a nodeb, then you must assume thatbis connected toa.
  • the graph will be strongly connected. That is, there will be at least one path from any node to any other node.

Input

The input consists of several test cases. Each test case starts with a line containing the numbern(1 <n< 200) of different nodes. The second line contains the number of edgesl. After this,llines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a numbera($0 \le a < n$).

An input withn= 0 will mark the end of the input and is not to be processed.

Output

You have to decide whether the input graph can be bicolored or not, and print it as shown below.

Sample Input

3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Sample Output

NOT BICOLORABLE.
BICOLORABLE.



Miguel Revilla
2000-08-21

有两种颜色,给一个无向图染色,要求相邻的点颜色不同。直接dfs。。这道题比较简单,但是我卡了很久。

#include<iostream>
#include<cstring>

using namespace std;

int grid[210][210];
int color[210];
int vis[210];
int tag,n,m;

void dfs(int pos)
{
    int k;
    for(k=0;k<n;k++)
    {
        if(grid[k][pos]==1&&vis[k]==0)
        {
            color[k]=1-color[pos];
            vis[k]=1;
            dfs(k);
        }
        else if(grid[k][pos]==1&&vis[k]==1)
        {
            if(color[k]==color[pos])
            {
                tag=0;
                return;
            }
        }
    }
}

int main()
{
    while(cin>>n&&n!=0)
    {
        memset(grid,0,sizeof(grid));
        memset(color,-1,sizeof(color));
        memset(vis,0,sizeof(vis));
        cin>>m;
        int i,j;
        while(m--)
        {
          cin>>i>>j;
          grid[i][j]=grid[j][i]=1;
        }
        vis[0]=1;
        color[0]=1;
        tag=1;
        dfs(0);
        if(tag) cout<<"BICOLORABLE."<<endl;
        else cout<<"NOT BICOLORABLE."<<endl;
    }
    return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics